Order Checkout Issues
Incident Report for See Tickets US
Resolved
We have resolved the issue affecting customer checkout for some events.
Posted Jul 28, 2023 - 08:29 PDT
Monitoring
A resolution is in progress, most checkout issues should be cleared, but some customers may see a queue before entering an event page.
Posted Jul 28, 2023 - 08:28 PDT
Investigating
We are currently investigating an issue affecting customer checkout. We'll update you once we have more information.
Posted Jul 28, 2023 - 08:26 PDT
This incident affected: Customer Website.