Payment Processor Disruption Causing Transaction Issues.
Incident Report for See Tickets US
Resolved
The disruption with our payment processor has been resolved. Online and the box office orders are going through as normal. Thank you for your patience on this matter.
Posted Mar 04, 2023 - 23:26 PST
Update
We are continuing to investigate this issue.
Posted Mar 04, 2023 - 22:27 PST
Investigating
A disruption with our payment process, Worldpay/Vantiv is causing delays in processing ticket orders. Ticket processing on the checkout page is taking significantly longer than expected. As soon as See Tickets has an update, we will publish on this page. Thank you for your patience.
Posted Mar 04, 2023 - 21:39 PST
This incident affected: Customer Website.