Online and Box Office Order Processing Issue
Incident Report for See Tickets US
Resolved
This issue has been resolved.
Posted Jun 20, 2023 - 15:16 PDT
Investigating
We are currently investigating an issue affecting customer checkout. We'll update you once we have more information.
Posted Jun 20, 2023 - 15:07 PDT
This incident affected: Customer Website.