Slow Response Time / Partial Site Unavailability
Incident Report for See Tickets US
Resolved
This issue has been resolved.
Posted Feb 21, 2024 - 10:30 PST
Identified
The issue has been identified and a resolution is in progress.
Posted Feb 21, 2024 - 10:15 PST
Investigating
We're investigating reports that some customers may be experiencing delays while using our platform. We will keep you updated as we identify a source and resolution for this. We appreciate your patience.
Posted Feb 21, 2024 - 10:00 PST
This incident affected: Customer Website.