Website, back-office and API disruptions

Incident Report for See Tickets US

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 14:01 PST

Update

All services are now operational. We are continuing to monitor the situation until our partner closes this incident.
Posted Nov 18, 2025 - 07:43 PST

Monitoring

Services are now accessible. Some regions may experience a few errors while loading our website.
Posted Nov 18, 2025 - 06:48 PST

Identified

Due to an infrastructure provider outage (Cloudflare), our services are currently unavailable or unstable.
We are monitoring the situation.
Posted Nov 18, 2025 - 04:15 PST
This incident affected: Event Pages & Checkout, Client Management Backoffice, Venue Management Backoffice, Box Office, and Third Party Components.