Order Checkout Issues
Incident Report for See Tickets US
Resolved
We have identified and resolved the issue affecting customer checkout for some events.
Posted Jul 25, 2023 - 15:22 PDT
Update
We are continuing to investigate this issue. It impacts only some of the events sold on See Tickets. We'll update you once we have more information.
Posted Jul 25, 2023 - 14:52 PDT
Investigating
We are currently investigating an issue affecting customer checkout. We'll update you once we have more information.
Posted Jul 25, 2023 - 14:39 PDT
This incident affected: Customer Website.