Order Checkout Issues
Incident Report for See Tickets US
Resolved
This incident only impacted internal platforms. Customers were not impacted. Thanks for your patience.
Posted Oct 26, 2023 - 11:52 PDT
Investigating
We are currently investigating an issue affecting customer checkout on new e-commerce pages. We'll update you once we have more information.
Posted Oct 26, 2023 - 11:13 PDT
This incident affected: Customer Website.